What’s Vulnerable › Vulnerabilities
CVE-2024-21622: Craft CMS Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-03 · updated 2026-06-17
- Weakness: CWE-269
Description
Craft is a content management system. This is a potential moderate impact, low complexity privilege escalation vulnerability in Craft starting in 3.x prior to 3.9.6 and 4.x prior to 4.4.16 with certain user permissions setups. This has been fixed in Craft 4.4.16 and Craft 3.9.6. Users should ensure they are running at least those versions.
Affected products
- craftcms cms: from 3.0.0 before 3.9.6; from 4.0.0 through 4.5.15 — fixed in 3.9.6
How to fix
Upgrade to a fixed version: craftcms cms 3.9.6. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/blob/develop/CHANGELOG.md#4511---2023-11-16
- https://github.com/craftcms/cms/blob/v3/CHANGELOG.md#396---2023-11-16
- https://github.com/craftcms/cms/commit/76caf9af07d9964be0fd362772223be6a5f5b6aa
- https://github.com/craftcms/cms/commit/be81eb653d633833f2ab22510794abb6bb9c0843
- https://github.com/craftcms/cms/pull/13931
- https://github.com/craftcms/cms/pull/13932
- https://github.com/craftcms/cms/security/advisories/GHSA-j5g9-j7r4-6qvx
- https://github.com/craftcms/cms/blob/develop/CHANGELOG.md#4511---2023-11-16
- https://github.com/craftcms/cms/blob/v3/CHANGELOG.md#396---2023-11-16
- https://github.com/craftcms/cms/commit/76caf9af07d9964be0fd362772223be6a5f5b6aa
- https://github.com/craftcms/cms/commit/be81eb653d633833f2ab22510794abb6bb9c0843
- https://github.com/craftcms/cms/pull/13931
Get alerted when CVE-2024-21622 or the next vulnerability affects your stack