What’s Vulnerable › Vulnerabilities
CVE-2024-21637: XSS in Authentik via JavaScript-URI as Redirect URI and form_post Response Mode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Authentik is an open-source Identity Provider. Authentik is a vulnerable to a reflected Cross-Site Scripting vulnerability via JavaScript-URIs in OpenID Connect flows with `response_mode=form_post`. This relatively user could use the described attacks to perform a privilege escalation. This vulnerability has been patched in versions 2023.10.6 and 2023.8.6.
Affected products
- goauthentik authentik: from 2023.8.0 before 2023.8.6; from 2023.10.0 before 2023.10.6 — fixed in 2023.10.6, 2023.8.6
How to fix
Upgrade to a fixed version: goauthentik authentik 2023.10.6, 2023.8.6. Check the vendor advisory for mitigations.
References
- https://github.com/goauthentik/authentik/releases/tag/version%2F2023.10.6
- https://github.com/goauthentik/authentik/releases/tag/version%2F2023.8.6
- https://github.com/goauthentik/authentik/security/advisories/GHSA-rjpr-7w8c-gv3j
- https://github.com/goauthentik/authentik/releases/tag/version%2F2023.10.6
- https://github.com/goauthentik/authentik/releases/tag/version%2F2023.8.6
- https://github.com/goauthentik/authentik/security/advisories/GHSA-rjpr-7w8c-gv3j
Get alerted when CVE-2024-21637 or the next vulnerability affects your stack