What’s Vulnerable › Vulnerabilities
CVE-2024-21642: D-Tale server-side request forgery through Web uploads
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-05 · updated 2026-06-17
- Weakness: CWE-918
Description
D-Tale is a visualizer for Pandas data structures. Users hosting versions D-Tale prior to 3.9.0 publicly can be vulnerable to server-side request forgery (SSRF), allowing attackers to access files on the server. Users should upgrade to version 3.9.0, where the `Load From the Web` input is turned off by default. The only workaround for versions earlier than 3.9.0 is to only host D-Tale to trusted users.
Affected products
- Man D-Tale: before 3.9.0 — fixed in 3.9.0
How to fix
Upgrade to a fixed version: Man D-Tale 3.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/man-group/dtale/commit/954f6be1a06ff8629ead2c85c6e3f8e2196b3df2
- https://github.com/man-group/dtale/security/advisories/GHSA-7hfx-h3j3-rwq4
- https://github.com/man-group/dtale?tab=readme-ov-file#load-data--sample-datasets
- https://github.com/man-group/dtale/commit/954f6be1a06ff8629ead2c85c6e3f8e2196b3df2
- https://github.com/man-group/dtale/security/advisories/GHSA-7hfx-h3j3-rwq4
- https://github.com/man-group/dtale?tab=readme-ov-file#load-data--sample-datasets
Get alerted when CVE-2024-21642 or the next vulnerability affects your stack