What’s Vulnerable › Vulnerabilities
CVE-2024-21647: HTTP Request/Response Smuggling in puma
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-08 · updated 2026-06-17
- Weakness: CWE-444
Description
Puma is a web server for Ruby/Rack applications built for parallelism. Prior to version 6.4.2, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies in a way that allowed HTTP request smuggling. Fixed versions limits the size of chunk extensions. Without this limit, an attacker could cause unbounded resource (CPU, network bandwidth) consumption. This vulnerability has been fixed in versions 6.4.2 and 5.6.8.
Affected products
- puma: before 5.6.8; from 6.0.0 before 6.4.2 — fixed in 5.6.8, 6.4.2
- Rubygems Puma: from 6.0.0 before 6.4.2; before 5.6.8; 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0 (+159) — fixed in 6.4.2, 5.6.8
How to fix
Upgrade to a fixed version: puma 5.6.8, 6.4.2; Rubygems Puma 6.4.2, 5.6.8. Check the vendor advisory for mitigations.
References
- https://github.com/puma/puma/commit/5fc43d73b6ff193325e657a24ed76dec79133e93
- https://github.com/puma/puma/security/advisories/GHSA-c2f4-cvqm-65w2
- https://github.com/puma/puma/commit/5fc43d73b6ff193325e657a24ed76dec79133e93
- https://github.com/puma/puma/security/advisories/GHSA-c2f4-cvqm-65w2
- https://lists.debian.org/debian-lts-announce/2024/11/msg00004.html
Get alerted when CVE-2024-21647 or the next vulnerability affects your stack