What’s Vulnerable › Vulnerabilities
CVE-2024-21650: XWiki Remote Code Execution vulnerability via user registration
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 93.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-08 · updated 2026-06-17
- Weakness: CWE-95
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. XWiki is vulnerable to a remote code execution (RCE) attack through its user registration feature. This issue allows an attacker to execute arbitrary code by crafting malicious payloads in the "first name" or "last name" fields during user registration. This impacts all installations that have user registration enabled for guests. This vulnerability has been patched in XWiki 14.10.17, 15.5.3 and 15.8 RC1.
Affected products
- xwiki-platform: before 14.10.17; from 15.0 before 15.5.3; from 15.6 through 15.7 — fixed in 14.10.17, 15.5.3
How to fix
Upgrade to a fixed version: xwiki-platform 14.10.17, 15.5.3. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/b290bfd573c6f7db6cc15a88dd4111d9fcad0d31
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-rj7p-xjv7-7229
- https://jira.xwiki.org/browse/XWIKI-21173
- https://github.com/xwiki/xwiki-platform/commit/b290bfd573c6f7db6cc15a88dd4111d9fcad0d31
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-rj7p-xjv7-7229
- https://jira.xwiki.org/browse/XWIKI-21173
Get alerted when CVE-2024-21650 or the next vulnerability affects your stack