What’s Vulnerable › Vulnerabilities
CVE-2024-21655: Insufficient control of custom field value sizes
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-12 · updated 2026-06-17
- Weakness: CWE-400
Description
Discourse is a platform for community discussion. For fields that are client editable, limits on sizes are not imposed. This allows a malicious actor to cause a Discourse instance to use excessive disk space and also often excessive bandwidth. The issue is patched 3.1.4 and 3.2.0.beta4.
Affected products
- discourse: before 3.1.4; 3.2.0-beta1, 3.2.0-beta2, 3.2.0-beta3 — fixed in 3.1.4
How to fix
Upgrade to a fixed version: discourse 3.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/security/advisories/GHSA-m5fc-94mm-38fx
- https://github.com/discourse/discourse/security/advisories/GHSA-m5fc-94mm-38fx
Get alerted when CVE-2024-21655 or the next vulnerability affects your stack