What’s Vulnerable › Vulnerabilities
CVE-2024-21674
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-94
Description
This High severity Remote Code Execution (RCE) vulnerability was introduced in version 7.13.0 of Confluence Data Center and Server. Remote Code Execution (RCE) vulnerability, with a CVSS Score of 8.6 and a CVSS Vector of CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N allows an unauthenticated attacker to expose assets in your environment susceptible to exploitation which has high impact to confidentiality, no impact to integrity, no impact to availability, and does not require user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: * Confluence Data Center and Server 7.19: Upgrade to a release 7.19.18, or any higher 7.19.x release * Confluence Data Center and Server 8.5: Upgrade to a release 8.5.5 or any higher 8.5.x release * Confluence Data Center and Server 8.7: Upgrade to a release 8.7.2 or any higher release See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html ). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives ).
Affected products
- Atlassian Confluence Data Center: from 7.19.0 before 7.19.18; from 8.5.0 before 8.5.5; from 8.7.0 before 8.7.2 — fixed in 7.19.18, 8.5.5, 8.7.2
- Atlassian Confluence Data Center: from 7.19 before 7.19.18; from 8.5.0 before 8.5.5; from 8.7.0 through 8.7.2 — fixed in 7.19.18, 8.5.5
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 7.19.18, 8.5.5, 8.7.2; Atlassian Confluence Data Center 7.19.18, 8.5.5. Check the vendor advisory for mitigations.
References
- https://jira.atlassian.com/browse/CONFSERVER-94066
- https://confluence.atlassian.com/security/security-bulletin-january-16-2024-1333335615.html
- https://jira.atlassian.com/browse/CONFSERVER-94066
Get alerted when CVE-2024-21674 or the next vulnerability affects your stack