What’s Vulnerable › Vulnerabilities
CVE-2024-21683
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 88.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-94
Description
This High severity RCE (Remote Code Execution) vulnerability was introduced in version 5.2 of Confluence Data Center and Server. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 7.2, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires no user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version. If you are unable to do so, upgrade your instance to one of the specified supported fixed versions. See the release notes https://confluence.atlassian.com/doc/confluence-release-notes-327.html You can download the latest version of Confluence Data Center and Server from the download center https://www.atlassian.com/software/confluence/download-archives. This vulnerability was found internally.
Affected products
- Atlassian Confluence Data Center: from 7.19.0 before 7.19.24; from 7.20.0 through 7.20.3; from 8.0.0 through 8.0.4; from 8.1.0 through 8.1.4; from 8.2.0 through 8.2.3; from 8.3.0 through 8.3.4 — fixed in 7.19.24, 8.5.11, 8.9.3
- Atlassian Confluence Data Center: from 7.19.0 before 7.19.24; from 7.20.0 through 7.20.3; from 8.0.0 through 8.0.4; from 8.1.0 through 8.1.4; from 8.2.0 through 8.2.3; from 8.3.0 through 8.3.4 — fixed in 7.19.24, 8.5.11
- Atlassian Crucible: from 4.8.0 before 4.8.15 — fixed in 4.8.15
- Atlassian Fisheye: from 4.8.0 before 4.8.15 — fixed in 4.8.15
- Atlassian Jira: from 9.4.0 before 9.4.21; from 9.12.0 before 9.12.8 — fixed in 9.12.8, 9.4.21
- Atlassian Jira: from 9.4.0 before 9.4.21; from 9.12.0 before 9.12.8 — fixed in 9.12.8, 9.4.21
- Atlassian Jira Service Management: from 5.4.0 before 5.4.21; from 5.12.0 before 5.12.8; from 5.15.2 before 5.16.0; 5.15.2 — fixed in 5.12.8, 5.16.0, 5.4.21
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 7.19.24, 8.5.11, 8.9.3; Atlassian Confluence Data Center 7.19.24, 8.5.11; Atlassian Crucible 4.8.15; Atlassian Fisheye 4.8.15; Atlassian Jira 9.12.8, 9.4.21; Atlassian Jira 9.12.8, 9.4.21; Atlassian Jira Service Management 5.12.8, 5.16.0, 5.4.21. Check the vendor advisory for mitigations.
References
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1409286211
- https://jira.atlassian.com/browse/CONFSERVER-95832
Get alerted when CVE-2024-21683 or the next vulnerability affects your stack