What’s Vulnerable › Vulnerabilities
CVE-2024-21686
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-16 · updated 2026-06-17
- Weakness: CWE-79
Description
This High severity Stored XSS vulnerability was introduced in versions 7.13 of Confluence Data Center and Server. This Stored XSS vulnerability, with a CVSS Score of 7.3, allows an authenticated attacker to execute arbitrary HTML or JavaScript code on a victims browser which has high impact to confidentiality, high impact to integrity, no impact to availability, and requires user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions listed on this CVE See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives). This vulnerability was reported via our Bug Bounty program.
Affected products
- Atlassian Confluence Data Center: before 7.19.22; from 7.20.0 before 8.5.9; from 8.6.0 before 8.9.1 — fixed in 7.19.22, 8.5.9, 8.9.1
- Atlassian Confluence Data Center: before 7.19.22; from 7.20.0 before 8.5.9 — fixed in 7.19.22, 8.5.9
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 7.19.22, 8.5.9, 8.9.1; Atlassian Confluence Data Center 7.19.22, 8.5.9. Check the vendor advisory for mitigations.
References
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1417150917
- https://jira.atlassian.com/browse/CONFSERVER-96134
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1417150917
- https://jira.atlassian.com/browse/CONFSERVER-96134
Get alerted when CVE-2024-21686 or the next vulnerability affects your stack