What’s Vulnerable › Vulnerabilities
CVE-2024-21687
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-16 · updated 2026-06-17
- Weakness: CWE-98
Description
This High severity File Inclusion vulnerability was introduced in versions 9.0.0, 9.1.0, 9.2.0, 9.3.0, 9.4.0, 9.5.0 and 9.6.0 of Bamboo Data Center and Server. This File Inclusion vulnerability, with a CVSS Score of 8.1, allows an authenticated attacker to get the application to display the contents of a local file, or execute a different files already stored locally on the server which has high impact to confidentiality, high impact to integrity, no impact to availability, and requires no user interaction. Atlassian recommends that Bamboo Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions listed on this CVE See the release notes (https://confluence.atlassian.com/bambooreleases/bamboo-release-notes-1189793869.html). You can download the latest version of Bamboo Data Center and Server from the download center (https://www.atlassian.com/software/bamboo/download-archives). This vulnerability was reported via our Bug Bounty program.
Affected products
- Atlassian Bamboo: from 9.0.0 through 9.0.4; from 9.1.0 through 9.1.3; from 9.2.0 before 9.2.16; from 9.3.0 through 9.3.6; from 9.4.0 through 9.4.3; from 9.5.0 through 9.5.4 — fixed in 9.2.16, 9.6.4
How to fix
Upgrade to a fixed version: Atlassian Bamboo 9.2.16, 9.6.4. Check the vendor advisory for mitigations.
References
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1417150917
- https://jira.atlassian.com/browse/BAM-25822
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1417150917
- https://jira.atlassian.com/browse/BAM-25822
Get alerted when CVE-2024-21687 or the next vulnerability affects your stack