What’s Vulnerable › Vulnerabilities
CVE-2024-2171: Stored XSS in zenml-io/zenml
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logo_url' field. By injecting malicious payloads into this field, an attacker could send harmful messages to other users, potentially compromising their accounts. The vulnerability affects version 0.55.3 and was fixed in version 0.56.2. The impact of exploiting this vulnerability could lead to user account compromise.
Affected products
- zenml-io/zenml: before 0.56.2 — fixed in 0.56.2
How to fix
Upgrade to a fixed version: zenml-io/zenml 0.56.2. Check the vendor advisory for mitigations.
References
- https://github.com/zenml-io/zenml/commit/68bcb3ba60cba9729c9713a49c39502d40fb945e
- https://huntr.com/bounties/cee06a28-7e3b-460b-b504-69add838ebe8
- https://github.com/zenml-io/zenml/commit/68bcb3ba60cba9729c9713a49c39502d40fb945e
- https://huntr.com/bounties/cee06a28-7e3b-460b-b504-69add838ebe8
Get alerted when CVE-2024-2171 or the next vulnerability affects your stack