What’s Vulnerable › Vulnerabilities
CVE-2024-21724: [20240203] - Core - XSS in media selection fields
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Inadequate input validation for media selection fields lead to XSS vulnerabilities in various extensions.
Affected products
- Joomla!: from 1.6.0 before 3.10.15; from 4.0.0 before 4.4.3; from 5.0.0 before 5.0.3 — fixed in 3.10.15, 4.4.3, 5.0.3
How to fix
Upgrade to a fixed version: Joomla! 3.10.15, 4.4.3, 5.0.3. Check the vendor advisory for mitigations.
References
- https://developer.joomla.org/security-centre/927-20240203-core-xss-in-media-selection-fields.html
- https://developer.joomla.org/security-centre/927-20240203-core-xss-in-media-selection-fields.html
Get alerted when CVE-2024-21724 or the next vulnerability affects your stack