What’s Vulnerable › Vulnerabilities
CVE-2024-21726: [20240205] - Core - Inadequate content filtering within the filter code
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 48.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Inadequate content filtering leads to XSS vulnerabilities in various components.
Affected products
- Joomla!: from 3.7.0 through 3.10.15; from 4.0.0 before 4.4.3; from 5.0.0 before 5.0.3 — fixed in 4.4.3, 5.0.3
How to fix
Upgrade to a fixed version: Joomla! 4.4.3, 5.0.3. Check the vendor advisory for mitigations.
References
- https://developer.joomla.org/security-centre/929-20240205-core-inadequate-content-filtering-within-the-filter-code.html
- https://www.sonarsource.com/blog/joomla-multiple-xss-vulnerabilities/
- https://developer.joomla.org/security-centre/929-20240205-core-inadequate-content-filtering-within-the-filter-code.html
Get alerted when CVE-2024-21726 or the next vulnerability affects your stack