What’s Vulnerable › Vulnerabilities
CVE-2024-21729: [20240701] - Core - XSS in accessible media selection field
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Inadequate input validation leads to XSS vulnerabilities in the accessiblemedia field.
Affected products
- Joomla!: from 4.0.0 before 4.4.6; from 5.0.0 before 5.1.2 — fixed in 4.4.6, 5.1.2
How to fix
Upgrade to a fixed version: Joomla! 4.4.6, 5.1.2. Check the vendor advisory for mitigations.
References
- https://developer.joomla.org/security-centre/935-20240701-core-xss-in-accessible-media-selection-field.html
- https://developer.joomla.org/security-centre/935-20240701-core-xss-in-accessible-media-selection-field.html
Get alerted when CVE-2024-21729 or the next vulnerability affects your stack