What’s Vulnerable › Vulnerabilities
CVE-2024-21730: [20240702] - Core - Self-XSS in fancyselect list field layout
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The fancyselect list field layout does not correctly escape inputs, leading to a self-XSS vector.
Affected products
- Joomla!: from 4.0.0 before 4.4.6; from 5.0.0 before 5.1.2 — fixed in 4.4.6, 5.1.2
How to fix
Upgrade to a fixed version: Joomla! 4.4.6, 5.1.2. Check the vendor advisory for mitigations.
References
- https://developer.joomla.org/security-centre/936-20240702-core-self-xss-in-fancyselect-list-field-layout.html
- https://developer.joomla.org/security-centre/936-20240702-core-self-xss-in-fancyselect-list-field-layout.html
Get alerted when CVE-2024-21730 or the next vulnerability affects your stack