What’s Vulnerable › Vulnerabilities

CVE-2024-21733: Apache Tomcat: Leaking of unrelated request bodies in default error page

Description

Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat.This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Other, EOL versions may also be affected. Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Tomcat 8.5.64, 9.0.44. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-21733 or the next vulnerability affects your stack