What’s Vulnerable › Vulnerabilities
CVE-2024-21747: WordPress WP ERP Plugin <= 1.12.8 is vulnerable to SQL Injection
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-08 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in weDevs WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting.This issue affects WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting: from n/a through 1.12.8.
Affected products
- weDevs WP ERP: before 1.12.9 — fixed in 1.12.9
How to fix
Upgrade to a fixed version: weDevs WP ERP 1.12.9. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/erp/wordpress-wp-erp-plugin-1-12-8-sql-injection-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/erp/wordpress-wp-erp-plugin-1-12-8-sql-injection-vulnerability?_s_id=cve
Get alerted when CVE-2024-21747 or the next vulnerability affects your stack