What’s Vulnerable › Vulnerabilities
CVE-2024-21756
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-78
Description
A improper neutralization of special elements used in an os command ('os command injection') vulnerability in Fortinet FortiSandbox 4.4.0 through 4.4.3, FortiSandbox 4.2.1 through 4.2.6, FortiSandbox 4.0.0 through 4.0.4 allows attacker to execute unauthorized code or commands via crafted requests..
Affected products
- Fortinet FortiSandbox: from 4.0.0 before 4.0.5; from 4.2.0 before 4.2.7; from 4.4.0 before 4.4.4 — fixed in 4.0.5, 4.2.7, 4.4.4
How to fix
Upgrade to a fixed version: Fortinet FortiSandbox 4.0.5, 4.2.7, 4.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-21756 or the next vulnerability affects your stack