What’s Vulnerable › Vulnerabilities

CVE-2024-21758

Description

A stack-based buffer overflow in Fortinet FortiWeb versions 7.2.0 through 7.2.7, and 7.4.0 through 7.4.1 may allow a privileged user to execute arbitrary code via specially crafted CLI commands, provided the user is able to evade FortiWeb stack protections.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiWeb 7.2.8, 7.4.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-21758 or the next vulnerability affects your stack