What’s Vulnerable › Vulnerabilities

CVE-2024-2177: Improper Restriction of Rendered UI Layers or Frames in GitLab

Description

A Cross Window Forgery vulnerability exists within GitLab CE/EE affecting all versions from 16.3 prior to 16.11.5, 17.0 prior to 17.0.3, and 17.1 prior to 17.1.1. This condition allows for an attacker to abuse the OAuth authentication flow via a crafted payload.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.11.5, 17.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-2177 or the next vulnerability affects your stack