What’s Vulnerable › Vulnerabilities
CVE-2024-2181: Beaver Builder Addons by WPZOOM <= 1.3.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Button Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Beaver Builder Addons by WPZOOM plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Button widget in all versions up to, and including, 1.3.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- WPZOOM Addons for Beaver Builder: before 1.3.5 — fixed in 1.3.5
How to fix
Upgrade to a fixed version: WPZOOM Addons for Beaver Builder 1.3.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3046905/wpzoom-addons-for-beaver-builder
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6baa44c7-1c13-45ad-9fb5-da06933f3cd0?source=cve
- https://plugins.trac.wordpress.org/changeset/3046905/wpzoom-addons-for-beaver-builder
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6baa44c7-1c13-45ad-9fb5-da06933f3cd0?source=cve
Get alerted when CVE-2024-2181 or the next vulnerability affects your stack