What’s Vulnerable › Vulnerabilities
CVE-2024-21838
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-05 · updated 2026-06-17
- Weakness: CWE-74
Description
Improper neutralization of special elements in output (CWE-74) used by the email generation feature of the Command Centre Server could lead to HTML code injection in emails generated by Command Centre. This issue affects: Gallagher Command Centre 9.00 prior to vEL9.00.1774 (MR2), 8.90 prior to vEL8.90.1751 (MR3), 8.80 prior to vEL8.80.1526 (MR4), 8.70 prior to vEL8.70.2526 (MR6), all version of 8.60 and prior.
Affected products
- Gallagher Command Centre: through 8.60; from 8.70 before 8.70.2526; from 8.80 before 8.80.1526; from 8.90 before 8.90.1751; from 9.00 before 9.00.1774 — fixed in 8.70.2526, 8.80.1526, 8.90.1751, 9.00.1774
How to fix
Upgrade to a fixed version: Gallagher Command Centre 8.70.2526, 8.80.1526, 8.90.1751, 9.00.1774. Check the vendor advisory for mitigations.
References
- https://security.gallagher.com/en-NZ/Security-Advisories/CVE-2024-21838
- https://security.gallagher.com/en-NZ/Security-Advisories/CVE-2024-21838
Get alerted when CVE-2024-21838 or the next vulnerability affects your stack