What’s Vulnerable › Vulnerabilities
CVE-2024-21840: Directory and File Permission Vulnerability in Hitachi Storage Plug-in for VMware vCenter
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-30 · updated 2026-06-17
- Weakness: CWE-276
Description
Incorrect Default Permissions vulnerability in Hitachi Storage Plug-in for VMware vCenter allows local users to read and write specific files. This issue affects Hitachi Storage Plug-in for VMware vCenter: from 04.0.0 through 04.9.2.
Affected products
- Hitachi Storage Plug-in for VMware vCenter: from 04.0.0 before 04.10.0 — fixed in 04.10.0
How to fix
Upgrade to a fixed version: Hitachi Storage Plug-in for VMware vCenter 04.10.0. Check the vendor advisory for mitigations.
References
- https://www.hitachi.com/products/it/software/security/info/vuls/hitachi-sec-2024-108/index.html
- https://www.hitachi.com/products/it/software/security/info/vuls/hitachi-sec-2024-108/index.html
Get alerted when CVE-2024-21840 or the next vulnerability affects your stack