What’s Vulnerable › Vulnerabilities
CVE-2024-2189: Social Icons Widget & Block < 4.2.18 - Admin+ Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Social Icons Widget & Block by WPZOOM WordPress plugin before 4.2.18 does not sanitise and escape some of its Widget settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Social Icons Widget & Block by WPZOOM: before 4.2.18 — fixed in 4.2.18
How to fix
Upgrade to a fixed version: Social Icons Widget & Block by WPZOOM 4.2.18. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b8661fbe-78b9-4d29-90bf-5b68af468eb6/
- https://wpscan.com/vulnerability/b8661fbe-78b9-4d29-90bf-5b68af468eb6/
Get alerted when CVE-2024-2189 or the next vulnerability affects your stack