What’s Vulnerable › Vulnerabilities
CVE-2024-21892
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-20 · updated 2026-06-17
- Weakness: CWE-94
Description
On Linux, Node.js ignores certain environment variables if those may have been set by an unprivileged user while the process is running with elevated privileges with the only exception of CAP_NET_BIND_SERVICE. Due to a bug in the implementation of this exception, Node.js incorrectly applies this exception even when certain other capabilities have been set. This allows unprivileged users to inject code that inherits the process's elevated privileges.
Affected products
- Node.js: from 18.0.0 before 18.19.1; from 20.0.0 before 20.11.1; from 21.0.0 before 21.6.2 — fixed in 18.19.1, 20.11.1, 21.6.2
How to fix
Upgrade to a fixed version: Node.js 18.19.1, 20.11.1, 21.6.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/11/1
- https://hackerone.com/reports/2237545
- https://security.netapp.com/advisory/ntap-20240322-0003/
- http://www.openwall.com/lists/oss-security/2024/03/11/1
- https://hackerone.com/reports/2237545
- https://security.netapp.com/advisory/ntap-20240322-0003/
Get alerted when CVE-2024-21892 or the next vulnerability affects your stack