What’s Vulnerable › Vulnerabilities
CVE-2024-21908: Cross-site scripting vulnerability in TinyMCE
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-03 · updated 2026-07-14
- Weakness: CWE-79
Description
TinyMCE versions before 5.9.0 are affected by a stored cross-site scripting vulnerability. An unauthenticated and remote attacker could insert crafted HTML into the editor resulting in arbitrary JavaScript execution in another user's browser.
Affected products
- tinymce: before 5.9.0 — fixed in 5.9.0
How to fix
Upgrade to a fixed version: tinymce 5.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-5h9g-x5rv-25wg
- https://github.com/tinymce/tinymce/security/advisories/GHSA-5h9g-x5rv-25wg
- https://vulncheck.com/advisories/vc-advisory-GHSA-5h9g-x5rv-25wg
- https://www.tiny.cloud/docs/release-notes/release-notes59/#securityfixes
- https://github.com/advisories/GHSA-5h9g-x5rv-25wg
- https://github.com/tinymce/tinymce/security/advisories/GHSA-5h9g-x5rv-25wg
- https://vulncheck.com/advisories/vc-advisory-GHSA-5h9g-x5rv-25wg
- https://www.tiny.cloud/docs/release-notes/release-notes59/#securityfixes
Get alerted when CVE-2024-21908 or the next vulnerability affects your stack