What’s Vulnerable › Vulnerabilities
CVE-2024-21909: Denial of service in CBOR library
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-03 · updated 2026-07-14
- Weakness: CWE-407
Description
PeterO.Cbor versions 4.0.0 through 4.5.0 are vulnerable to a denial of service vulnerability. An attacker may trigger the denial of service condition by providing crafted data to the DecodeFromBytes or other decoding mechanisms in PeterO.Cbor. Depending on the usage of the library, an unauthenticated and remote attacker may be able to cause the denial of service condition.
Affected products
- Peteroupc Cbor: from 4.0.0 before 4.5.1 — fixed in 4.5.1
How to fix
Upgrade to a fixed version: Peteroupc Cbor 4.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-6r92-cgxc-r5fg
- https://github.com/peteroupc/CBOR/commit/b4117dbbb4cd5a4a963f9d0c9aa132f033e15b95
- https://github.com/peteroupc/CBOR/compare/v4.5...v4.5.1
- https://github.com/peteroupc/CBOR/security/advisories/GHSA-6r92-cgxc-r5fg
- https://vulncheck.com/advisories/vc-advisory-GHSA-6r92-cgxc-r5fg
- https://github.com/advisories/GHSA-6r92-cgxc-r5fg
- https://github.com/peteroupc/CBOR/commit/b4117dbbb4cd5a4a963f9d0c9aa132f033e15b95
- https://github.com/peteroupc/CBOR/compare/v4.5...v4.5.1
- https://github.com/peteroupc/CBOR/security/advisories/GHSA-6r92-cgxc-r5fg
- https://vulncheck.com/advisories/vc-advisory-GHSA-6r92-cgxc-r5fg
Get alerted when CVE-2024-21909 or the next vulnerability affects your stack