What’s Vulnerable › Vulnerabilities
CVE-2024-2191: Improper Access Control in GitLab
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-27 · updated 2026-06-17
- Weakness: CWE-284
Description
An issue was discovered in GitLab CE/EE affecting all versions starting from 16.9 prior to 16.11.5, starting from 17.0 prior to 17.0.3, and starting from 17.1 prior to 17.1.1, which allows merge request title to be visible publicly despite being set as project members only.
Affected products
- GitLab: from 16.9.0 before 16.11.5; from 17.0.0 before 17.0.3; 17.1.0 — fixed in 16.11.5, 17.0.3
How to fix
Upgrade to a fixed version: GitLab 16.11.5, 17.0.3. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/444655
- https://hackerone.com/reports/2357370
- https://gitlab.com/gitlab-org/gitlab/-/issues/444655
- https://hackerone.com/reports/2357370
Get alerted when CVE-2024-2191 or the next vulnerability affects your stack