What’s Vulnerable › Vulnerabilities
CVE-2024-21911: Cross-site scripting vulnerability in TinyMCE
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-03 · updated 2026-07-14
- Weakness: CWE-79
Description
TinyMCE versions before 5.6.0 are affected by a stored cross-site scripting vulnerability. An unauthenticated and remote attacker could insert crafted HTML into the editor resulting in arbitrary JavaScript execution in another user's browser.
Affected products
- tinymce: before 5.6.0 — fixed in 5.6.0
How to fix
Upgrade to a fixed version: tinymce 5.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-w7jx-j77m-wp65
- https://github.com/tinymce/tinymce/security/advisories/GHSA-w7jx-j77m-wp65
- https://vulncheck.com/advisories/vc-advisory-GHSA-w7jx-j77m-wp65
- https://www.npmjs.com/package/tinymce
- https://www.tiny.cloud/docs/release-notes/release-notes56/#securityfixes
- https://github.com/advisories/GHSA-w7jx-j77m-wp65
- https://github.com/tinymce/tinymce/security/advisories/GHSA-w7jx-j77m-wp65
- https://vulncheck.com/advisories/vc-advisory-GHSA-w7jx-j77m-wp65
- https://www.npmjs.com/package/tinymce
- https://www.tiny.cloud/docs/release-notes/release-notes56/#securityfixes
Get alerted when CVE-2024-21911 or the next vulnerability affects your stack