What’s Vulnerable › Vulnerabilities
CVE-2024-21915: Rockwell Automation FactoryTalk® Service Platform Elevated Privileges Vulnerability Through Web Service Functionality
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-16 · updated 2026-06-17
- Weakness: CWE-732
Description
A privilege escalation vulnerability exists in Rockwell Automation FactoryTalk® Service Platform (FTSP). If exploited, a malicious user with basic user group privileges could potentially sign into the software and receive FTSP Administrator Group privileges. A threat actor could potentially read and modify sensitive data, delete data and render the FTSP system unavailable.
Affected products
- Rockwell Automation FactoryTalk Services Platform: before 2.74 — fixed in 2.74
How to fix
Upgrade to a fixed version: Rockwell Automation FactoryTalk Services Platform 2.74. Check the vendor advisory for mitigations.
References
- https://www.rockwellautomation.com/en-us/support/advisory.SD1662.html
- https://www.rockwellautomation.com/en-us/support/advisory.SD1662.html
Get alerted when CVE-2024-21915 or the next vulnerability affects your stack