What’s Vulnerable › Vulnerabilities
CVE-2024-21984: Reflected Cross-Site Scripting Vulnerability in StorageGRID (formerly StorageGRID Webscale)
- Severity: medium (CVSS 6.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-16 · updated 2026-06-17
- Weakness: CWE-79
Description
StorageGRID (formerly StorageGRID Webscale) versions prior to 11.8 are susceptible to a difficult to exploit Reflected Cross-Site Scripting (XSS) vulnerability. Successful exploit requires the attacker to know specific information about the target instance and trick a privileged user into clicking a specially crafted link. This could allow the attacker to view or modify configuration settings or add or modify user accounts.
Affected products
- NetApp StorageGRID: before 11.7.0.8 — fixed in 11.7.0.8
How to fix
Upgrade to a fixed version: NetApp StorageGRID 11.7.0.8. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20240216-0013/
- https://security.netapp.com/advisory/ntap-20240216-0013/
Get alerted when CVE-2024-21984 or the next vulnerability affects your stack