What’s Vulnerable › Vulnerabilities
CVE-2024-21994: CVE-2024-21994 Denial of Service Vulnerability in StorageGRID (formerly StorageGRID Webscale)
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-08 · updated 2026-06-17
- Weakness: CWE-770
Description
StorageGRID (formerly StorageGRID Webscale) versions prior to 11.9 are susceptible to a Denial of Service (DoS) vulnerability. Successful exploit by an authenticated attacker could lead to a service crash.
Affected products
- NetApp StorageGRID: before 11.9.0 — fixed in 11.9.0
How to fix
Upgrade to a fixed version: NetApp StorageGRID 11.9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-21994 or the next vulnerability affects your stack