What’s Vulnerable › Vulnerabilities
CVE-2024-2200: Contact Form by BestWebSoft <= 4.2.8 - Reflected Cross-Site Scripting via cntctfrm_contact_subject
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Contact Form by BestWebSoft plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘cntctfrm_contact_subject’ parameter in all versions up to, and including, 4.2.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- BestWebSoft Contact Form Plugin: before 4.2.9 — fixed in 4.2.9
How to fix
Upgrade to a fixed version: BestWebSoft Contact Form Plugin 4.2.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3047840/contact-form-plugin
- https://www.wordfence.com/threat-intel/vulnerabilities/id/28524702-3428-4fca-afe8-71b3f2dd983d?source=cve
- https://plugins.trac.wordpress.org/changeset/3047840/contact-form-plugin
- https://www.wordfence.com/threat-intel/vulnerabilities/id/28524702-3428-4fca-afe8-71b3f2dd983d?source=cve
Get alerted when CVE-2024-2200 or the next vulnerability affects your stack