What’s Vulnerable › Vulnerabilities
CVE-2024-22017
- Severity: high (CVSS 7.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-19 · updated 2026-06-17
- Weakness: CWE-250
Description
setuid() does not affect libuv's internal io_uring operations if initialized before the call to setuid(). This allows the process to perform privileged operations despite presumably having dropped such privileges through a call to setuid(). This vulnerability affects all users using version greater or equal than Node.js 18.18.0, Node.js 20.4.0 and Node.js 21.
Affected products
- nodejs: from 18.0.0 before 18.18.0; from 20.0.0 before 20.4.0; from 21.0.0 before 21.6.1 — fixed in 18.18.0, 20.4.0, 21.6.1
How to fix
Upgrade to a fixed version: nodejs 18.18.0, 20.4.0, 21.6.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/11/1
- https://hackerone.com/reports/2170226
- https://security.netapp.com/advisory/ntap-20240517-0007/
- http://www.openwall.com/lists/oss-security/2024/03/11/1
- https://hackerone.com/reports/2170226
- https://security.netapp.com/advisory/ntap-20240517-0007/
Get alerted when CVE-2024-22017 or the next vulnerability affects your stack