What’s Vulnerable › Vulnerabilities
CVE-2024-2202: Page Builder by SiteOrigin <= 2.29.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via Legacy Image Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The Page Builder by SiteOrigin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the legacy Image widget in all versions up to, and including, 2.29.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- gpriday Page Builder by SiteOrigin: before 2.29.7 — fixed in 2.29.7
How to fix
Upgrade to a fixed version: gpriday Page Builder by SiteOrigin 2.29.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/siteorigin-panels/trunk/widgets/widgets.php#L911
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3053935%40siteorigin-panels&new=3053935%40siteorigin-panels&sfp_email=&sfph_mail=#file31
- https://www.wordfence.com/threat-intel/vulnerabilities/id/52116a6f-506f-4eeb-9bcc-19900ef38101?source=cve
- https://plugins.trac.wordpress.org/browser/siteorigin-panels/trunk/widgets/widgets.php#L911
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3053935%40siteorigin-panels&new=3053935%40siteorigin-panels&sfp_email=&sfph_mail=#file31
- https://www.wordfence.com/threat-intel/vulnerabilities/id/52116a6f-506f-4eeb-9bcc-19900ef38101?source=cve
Get alerted when CVE-2024-2202 or the next vulnerability affects your stack