What’s Vulnerable › Vulnerabilities
CVE-2024-22029: tomcat packaging allows for escalation to root from tomcat user
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-732
Description
Insecure permissions in the packaging of tomcat allow local users that win a race during package installation to escalate to root
Affected products
- SUSE Container suse/manager/5.0/x86_64/server:5.0.0-beta1.2.122: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE openSUSE Leap 15.5: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE openSUSE Tumbleweed: from ? before 9.0.85-3.1 — fixed in 9.0.85-3.1
- SUSE Enterprise Storage 7.1: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise High Performance Computing 15 SP5: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise High Performance Computing 15 SP6: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise Module for Web and Scripting 15 SP5: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise Module for Web and Scripting 15 SP6: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise Server 15 SP2-LTSS: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise Server 15 SP3-LTSS: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise Server 15 SP4-LTSS: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise Server 15 SP5: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise Server 15 SP6: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise Server for SAP Applications 15 SP2: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise Server for SAP Applications 15 SP3: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise Server for SAP Applications 15 SP4: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise Server for SAP Applications 15 SP5: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Linux Enterprise Server for SAP Applications 15 SP6: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
- SUSE Manager Server 4.3: from ? before 9.0.85-150200.57.1 — fixed in 9.0.85-150200.57.1
How to fix
Upgrade to a fixed version: SUSE Container suse/manager/5.0/x86_64/server:5.0.0-beta1.2.122 9.0.85-150200.57.1; SUSE openSUSE Leap 15.5 9.0.85-150200.57.1; SUSE openSUSE Tumbleweed 9.0.85-3.1; SUSE Enterprise Storage 7.1 9.0.85-150200.57.1; SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS 9.0.85-150200.57.1; SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS 9.0.85-150200.57.1; SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS 9.0.85-150200.57.1; SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS 9.0.85-150200.57.1; SUSE Linux Enterprise High Performance Computing 15 SP5 9.0.85-150200.57.1; SUSE Linux Enterprise High Performance Computing 15 SP6 9.0.85-150200.57.1; SUSE Linux Enterprise Module for Web and Scripting 15 SP5 9.0.85-150200.57.1; SUSE Linux Enterprise Module for Web and Scripting 15 SP6 9.0.85-150200.57.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-22029 or the next vulnerability affects your stack