What’s Vulnerable › Vulnerabilities
CVE-2024-22030: Rancher agents can be hijacked by taking over the Rancher Server URL
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-295
Description
A vulnerability has been identified within Rancher that can be exploited in narrow circumstances through a man-in-the-middle (MITM) attack. An attacker would need to have control of an expired domain or execute a DNS spoofing/hijacking attack against the domain to exploit this vulnerability. The targeted domain is the one used as the Rancher URL.
Affected products
- SUSE Rancher: from 2.7.0 before 2.7.15; from 2.8.0 before 2.8.8; from 2.9.0 before 2.9.2 — fixed in 2.7.15, 2.8.8, 2.9.2
How to fix
Upgrade to a fixed version: SUSE Rancher 2.7.15, 2.8.8, 2.9.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2024-22030
- https://github.com/rancher/rancher/security/advisories/GHSA-h4h5-9833-v2p4
Get alerted when CVE-2024-22030 or the next vulnerability affects your stack