What’s Vulnerable › Vulnerabilities
CVE-2024-22033: obs-service-download_url is vulnerable to argument injection
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-78
Description
The OBS service obs-service-download_url was vulnerable to a command injection vulnerability. The attacker could provide a configuration to the service that allowed to execute command in later steps
Affected products
- SUSE openSUSE Leap 15.5: from ? before 0.2.1-bp155.3.3.1 — fixed in 0.2.1-bp155.3.3.1
- SUSE openSUSE Leap 15.6: from ? before 0.2.1-bp156.2.3.1 — fixed in 0.2.1-bp156.2.3.1
- SUSE openSUSE Tumbleweed: from ? before 0.2.1-1.1 — fixed in 0.2.1-1.1
- SUSE Package Hub 15 SP5: from ? before 0.2.1-bp155.3.3.1 — fixed in 0.2.1-bp155.3.3.1
- SUSE Package Hub 15 SP6: from ? before 0.2.1-bp156.2.3.1 — fixed in 0.2.1-bp156.2.3.1
How to fix
Upgrade to a fixed version: SUSE openSUSE Leap 15.5 0.2.1-bp155.3.3.1; SUSE openSUSE Leap 15.6 0.2.1-bp156.2.3.1; SUSE openSUSE Tumbleweed 0.2.1-1.1; SUSE Package Hub 15 SP5 0.2.1-bp155.3.3.1; SUSE Package Hub 15 SP6 0.2.1-bp156.2.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-22033 or the next vulnerability affects your stack