What’s Vulnerable › Vulnerabilities
CVE-2024-22034: Crafted projects can overwrite special files in the .osc config directory
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
Description
Attackers could put the special files in .osc into the actual package sources (e.g. _apiurl). This allows the attacker to change the configuration of osc for the victim
Affected products
- SUSE openSUSE Leap 15.5: from ? before 1.9.0-150400.10.6.1 — fixed in 1.9.0-150400.10.6.1
- SUSE openSUSE Leap 15.6: from ? before 1.9.0-150400.10.6.1 — fixed in 1.9.0-150400.10.6.1
- SUSE openSUSE Tumbleweed: from ? before 1.9.0-1.1 — fixed in 1.9.0-1.1
- SUSE Linux Enterprise Desktop 15 SP5: from ? before 1.9.0-150400.10.6.1 — fixed in 1.9.0-150400.10.6.1
- SUSE Linux Enterprise Desktop 15 SP6: from ? before 1.9.0-150400.10.6.1 — fixed in 1.9.0-150400.10.6.1
- SUSE Linux Enterprise High Performance Computing 15 SP5: from ? before 1.9.0-150400.10.6.1 — fixed in 1.9.0-150400.10.6.1
- SUSE Linux Enterprise High Performance Computing 15 SP6: from ? before 1.9.0-150400.10.6.1 — fixed in 1.9.0-150400.10.6.1
- SUSE Linux Enterprise Module for Development Tools 15 SP5: from ? before 1.9.0-150400.10.6.1 — fixed in 1.9.0-150400.10.6.1
- SUSE Linux Enterprise Module for Development Tools 15 SP6: from ? before 1.9.0-150400.10.6.1 — fixed in 1.9.0-150400.10.6.1
- SUSE Linux Enterprise Server 12 SP5: from ? before 0.183.0-15.18.1 — fixed in 0.183.0-15.18.1
- SUSE Linux Enterprise Server 15 SP5: from ? before 1.9.0-150400.10.6.1 — fixed in 1.9.0-150400.10.6.1
- SUSE Linux Enterprise Server 15 SP6: from ? before 1.9.0-150400.10.6.1 — fixed in 1.9.0-150400.10.6.1
- SUSE Linux Enterprise Server for SAP Applications 12 SP5: from ? before 0.183.0-15.18.1 — fixed in 0.183.0-15.18.1
- SUSE Linux Enterprise Server for SAP Applications 15 SP5: from ? before 1.9.0-150400.10.6.1 — fixed in 1.9.0-150400.10.6.1
- SUSE Linux Enterprise Server for SAP Applications 15 SP6: from ? before 1.9.0-150400.10.6.1 — fixed in 1.9.0-150400.10.6.1
- SUSE Linux Enterprise Software Development Kit 12 SP5: from ? before 0.183.0-15.18.1 — fixed in 0.183.0-15.18.1
How to fix
Upgrade to a fixed version: SUSE openSUSE Leap 15.5 1.9.0-150400.10.6.1; SUSE openSUSE Leap 15.6 1.9.0-150400.10.6.1; SUSE openSUSE Tumbleweed 1.9.0-1.1; SUSE Linux Enterprise Desktop 15 SP5 1.9.0-150400.10.6.1; SUSE Linux Enterprise Desktop 15 SP6 1.9.0-150400.10.6.1; SUSE Linux Enterprise High Performance Computing 15 SP5 1.9.0-150400.10.6.1; SUSE Linux Enterprise High Performance Computing 15 SP6 1.9.0-150400.10.6.1; SUSE Linux Enterprise Module for Development Tools 15 SP5 1.9.0-150400.10.6.1; SUSE Linux Enterprise Module for Development Tools 15 SP6 1.9.0-150400.10.6.1; SUSE Linux Enterprise Server 12 SP5 0.183.0-15.18.1; SUSE Linux Enterprise Server 15 SP5 1.9.0-150400.10.6.1; SUSE Linux Enterprise Server 15 SP6 1.9.0-150400.10.6.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-22034 or the next vulnerability affects your stack