What’s Vulnerable › Vulnerabilities
CVE-2024-22047: Audited Log Integrity Errors Due to Race Condition
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-04 · updated 2026-10-29
- Weakness: CWE-362
Description
A race condition exists in Audited 4.0.0 before 5.3.3 that can result in an authenticated user to cause audit log entries to be attributed to another user.
Affected products
- Collectiveidea Audited: from 4.0.0 before 5.3.3 — fixed in 5.3.3
- audited: from 4.0.0 before 5.3.3 — fixed in 5.3.3
How to fix
Upgrade to a fixed version: Collectiveidea Audited 5.3.3; audited 5.3.3. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-hjp3-5g2q-7jww
- https://github.com/collectiveidea/audited/issues/601
- https://github.com/collectiveidea/audited/pull/669
- https://github.com/collectiveidea/audited/pull/671
- https://github.com/collectiveidea/audited/security/advisories/GHSA-hjp3-5g2q-7jww
- https://vulncheck.com/advisories/vc-advisory-GHSA-hjp3-5g2q-7jww
- https://github.com/advisories/GHSA-hjp3-5g2q-7jww
- https://github.com/collectiveidea/audited/issues/601
- https://github.com/collectiveidea/audited/pull/669
- https://github.com/collectiveidea/audited/pull/671
- https://github.com/collectiveidea/audited/security/advisories/GHSA-hjp3-5g2q-7jww
- https://vulncheck.com/advisories/vc-advisory-GHSA-hjp3-5g2q-7jww
Get alerted when CVE-2024-22047 or the next vulnerability affects your stack