What’s Vulnerable › Vulnerabilities
CVE-2024-22048: govuk_tech_docs XSS Vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-04 · updated 2026-07-14
- Weakness: CWE-79
Description
govuk_tech_docs versions from 2.0.2 to before 3.3.1 are vulnerable to a cross-site scripting vulnerability. Malicious JavaScript may be executed in the user's browser if a malicious search result is displayed on the search page.
Affected products
- Gov.Uk Govuk Tech Docs: from 2.0.2 before 3.3.1 — fixed in 3.3.1
How to fix
Upgrade to a fixed version: Gov.Uk Govuk Tech Docs 3.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-x2xw-hw8g-6773
- https://github.com/alphagov/tech-docs-gem/pull/323
- https://github.com/alphagov/tech-docs-gem/releases/tag/v3.3.1
- https://github.com/alphagov/tech-docs-gem/security/advisories/GHSA-x2xw-hw8g-6773
- https://vulncheck.com/advisories/vc-advisory-GHSA-x2xw-hw8g-6773
- https://github.com/advisories/GHSA-x2xw-hw8g-6773
- https://github.com/alphagov/tech-docs-gem/pull/323
- https://github.com/alphagov/tech-docs-gem/releases/tag/v3.3.1
- https://github.com/alphagov/tech-docs-gem/security/advisories/GHSA-x2xw-hw8g-6773
- https://vulncheck.com/advisories/vc-advisory-GHSA-x2xw-hw8g-6773
Get alerted when CVE-2024-22048 or the next vulnerability affects your stack