What’s Vulnerable › Vulnerabilities

CVE-2024-22051: CommonMarker Integer Overflow Vulnerability

Description

CommonMarker versions prior to 0.23.4 are at risk of an integer overflow vulnerability. This vulnerability can result in possibly unauthenticated remote attackers to cause heap memory corruption, potentially leading to an information leak or remote code execution, via parsing tables with marker rows that contain more than UINT16_MAX columns.

Affected products

How to fix

Upgrade to a fixed version: github cmark-gfm 0.28.3.gfm.21, 0.29.0.gfm.3; Gjtorikian Commonmarker 0.23.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-22051 or the next vulnerability affects your stack