What’s Vulnerable › Vulnerabilities
CVE-2024-22076
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-23 · updated 2026-06-17
Description
MyQ Print Server before 8.2 patch 43 allows remote authenticated administrators to execute arbitrary code via PHP scripts that are reached through the administrative interface.
Affected products
- Myq-Solution Print Server: before 8.2; 8.2, 8.2-beta1, 8.2-patch1, 8.2-patch10, 8.2-patch11, 8.2-patch12 (+41) — fixed in 8.2
How to fix
Upgrade to a fixed version: Myq-Solution Print Server 8.2. Check the vendor advisory for mitigations.
References
- https://docs.myq-solution.com/en/print-server/8.2/
- https://docs.myq-solution.com/en/print-server/8.2/technical-changelog#id-%288.2%29ReleaseNotes-8.2%28Patch43%29
- https://www.access42.nl/nieuws/unmasking-web-vulnerabilities-a-tale-of-default-admin-credentials-and-php-command-execution-cve-2024-22076/
- https://docs.myq-solution.com/en/print-server/8.2/
- https://docs.myq-solution.com/en/print-server/8.2/technical-changelog#id-%288.2%29ReleaseNotes-8.2%28Patch43%29
- https://www.access42.nl/nieuws/unmasking-web-vulnerabilities-a-tale-of-default-admin-credentials-and-php-command-execution-cve-2024-22076/
Get alerted when CVE-2024-22076 or the next vulnerability affects your stack