What’s Vulnerable › Vulnerabilities
CVE-2024-22078
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-20 · updated 2026-06-17
- Weakness: CWE-280
Description
An issue was discovered in Elspec G5 digital fault recorder versions 1.1.4.15 and before. Privilege escalation can occur via world writable files. The network configuration script has weak filesystem permissions. This results in write access for all authenticated users and the possibility to escalate from user privileges to administrative privileges.
Affected products
- Elspec-Ltd G5Dfr Firmware: before 1.2.1.12 — fixed in 1.2.1.12
How to fix
Upgrade to a fixed version: Elspec-Ltd G5Dfr Firmware 1.2.1.12. Check the vendor advisory for mitigations.
References
- https://www.elspec-ltd.com/support/security-advisories/
- https://www.elspec-ltd.com/support/security-advisories/
Get alerted when CVE-2024-22078 or the next vulnerability affects your stack