What’s Vulnerable › Vulnerabilities
CVE-2024-22100: MicroDicom DICOM Heap-based Buffer Overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-01 · updated 2026-06-17
- Weakness: CWE-122
Description
MicroDicom DICOM Viewer versions 2023.3 (Build 9342) and prior are affected by a heap-based buffer overflow vulnerability, which could allow an attacker to execute arbitrary code on affected installations of DICOM Viewer. A user must open a malicious DCM file in order to exploit the vulnerability.
Affected products
- MicroDicom DICOM Viewer: before 2024.1 — fixed in 2024.1
How to fix
Upgrade to a fixed version: MicroDicom DICOM Viewer 2024.1. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/news-events/ics-medical-advisories/icsma-24-060-01
- https://www.cisa.gov/news-events/ics-medical-advisories/icsma-24-060-01
Get alerted when CVE-2024-22100 or the next vulnerability affects your stack