What’s Vulnerable › Vulnerabilities
CVE-2024-22119: Stored XSS in graph items select form
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-09 · updated 2026-06-17
- Weakness: CWE-20
Description
The cause of vulnerability is improper validation of form input field “Name” on Graph page in Items section.
Affected products
- Zabbix: from 5.0.0 before 5.0.40; from 6.0.0 before 6.0.24; from 6.4.0 before 6.4.9; 7.0.0-alpha1, 7.0.0-alpha2, 7.0.0-alpha3, 7.0.0-alpha4, 7.0.0-alpha5, 7.0.0-alpha6 (+1) — fixed in 5.0.40, 6.0.24, 6.4.9
How to fix
Upgrade to a fixed version: Zabbix 5.0.40, 6.0.24, 6.4.9. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2024/04/msg00020.html
- https://support.zabbix.com/browse/ZBX-24070
- https://lists.debian.org/debian-lts-announce/2024/04/msg00020.html
- https://lists.debian.org/debian-lts-announce/2024/10/msg00000.html
- https://support.zabbix.com/browse/ZBX-24070
Get alerted when CVE-2024-22119 or the next vulnerability affects your stack