What’s Vulnerable › Vulnerabilities
CVE-2024-22129: Cross-Site Scripting (XSS) vulnerability in SAP Companion
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-13 · updated 2026-06-17
- Weakness: CWE-79
Description
SAP Companion - version <3.1.38, has a URL with parameter that could be vulnerable to XSS attack. The attacker could send a malicious link to a user that would possibly allow an attacker to retrieve the sensitive information and cause minor impact on the integrity of the web application.
Affected products
- SAP_SE SAP Companion: before 3.1.38 — fixed in 3.1.38
How to fix
Upgrade to a fixed version: SAP_SE SAP Companion 3.1.38. Check the vendor advisory for mitigations.
References
- https://me.sap.com/notes/3404025
- https://www.sap.com/documents/2022/02/fa865ea4-167e-0010-bca6-c68f7e60039b.html
- https://me.sap.com/notes/3404025
- https://www.sap.com/documents/2022/02/fa865ea4-167e-0010-bca6-c68f7e60039b.html
Get alerted when CVE-2024-22129 or the next vulnerability affects your stack