What’s Vulnerable › Vulnerabilities
CVE-2024-22158: WordPress PeepSo Core: Photos Plugin < 6.3.1.0 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PeepSo Community by PeepSo – Social Network, Membership, Registration, User Profiles allows Stored XSS.This issue affects Community by PeepSo – Social Network, Membership, Registration, User Profiles: from n/a before 6.3.1.0.
Affected products
- PeepSo Community by PeepSo – Social Network, Membership, Registration, User Profiles: before 6.3.1.0 — fixed in 6.3.1.0
How to fix
Upgrade to a fixed version: PeepSo Community by PeepSo – Social Network, Membership, Registration, User Profiles 6.3.1.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/peepso-photos/wordpress-peepso-photos-add-on-plugin-6-3-1-0-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/peepso-photos/wordpress-peepso-photos-add-on-plugin-6-3-1-0-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-22158 or the next vulnerability affects your stack