What’s Vulnerable › Vulnerabilities
CVE-2024-22206: @clerk/nextjs auth() and getAuth() methods vulnerable to insecure direct object reference (IDOR)
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-12 · updated 2026-06-17
- Weakness: CWE-284
Description
Clerk helps developers build user management. Unauthorized access or privilege escalation due to a logic flaw in auth() in the App Router or getAuth() in the Pages Router. This vulnerability was patched in version 4.29.3.
Affected products
- clerk javascript: from 4.7.0 before 4.29.3 — fixed in 4.29.3
How to fix
Upgrade to a fixed version: clerk javascript 4.29.3. Check the vendor advisory for mitigations.
References
- https://clerk.com/changelog/2024-01-12
- https://github.com/clerk/javascript/releases/tag/%40clerk%2Fnextjs%404.29.3
- https://github.com/clerk/javascript/security/advisories/GHSA-q6w5-jg5q-47vg
- https://clerk.com/changelog/2024-01-12
- https://github.com/clerk/javascript/releases/tag/%40clerk%2Fnextjs%404.29.3
- https://github.com/clerk/javascript/security/advisories/GHSA-q6w5-jg5q-47vg
Get alerted when CVE-2024-22206 or the next vulnerability affects your stack