What’s Vulnerable › Vulnerabilities
CVE-2024-22207: Default swagger-ui configuration exposes all files in the module
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-15 · updated 2026-06-17
- Weakness: CWE-1188
Description
fastify-swagger-ui is a Fastify plugin for serving Swagger UI. Prior to 2.1.0, the default configuration of `@fastify/swagger-ui` without `baseDir` set will lead to all files in the module's directory being exposed via http routes served by the module. The vulnerability is fixed in v2.1.0. Setting the `baseDir` option can also work around this vulnerability.
Affected products
- fastify-swagger-ui: from 2.0.0 before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: fastify-swagger-ui 2.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/fastify/fastify-swagger-ui/commit/13d799a2c5f14d3dd5b15892e03bbcbae63ee6f7
- https://github.com/fastify/fastify-swagger-ui/security/advisories/GHSA-62jr-84gf-wmg4
- https://security.netapp.com/advisory/ntap-20240216-0002/
- https://github.com/fastify/fastify-swagger-ui/commit/13d799a2c5f14d3dd5b15892e03bbcbae63ee6f7
- https://github.com/fastify/fastify-swagger-ui/security/advisories/GHSA-62jr-84gf-wmg4
- https://security.netapp.com/advisory/ntap-20240216-0002/
Get alerted when CVE-2024-22207 or the next vulnerability affects your stack